CTAN Comprehensive TeX Archive Network

CTAN update: glossaries-extra

Date: February 15, 2020 10:55:44 AM CET
Nicola Talbot submitted an update to the glossaries-extra package. Version number: 1.42 2020-02-13 License type: lppl1.3 Summary description: An extension to the glossaries package Announcement text:
Bug fixes: - corrected interference caused by 'acronym'/'acronyms' package option with abbreviation display style - moved \protect inside \glsxtrscsuffix (otherwise it interferes with all caps) - corrected missing space factor with 'insertdots' attribute - \glslink with record was causing an undefined control sequence error (\glslabel) in the post-link hook when entries are undefined - restored original definition of \glsdohyperlink and added \glsxtrdohyperlink to reference attributes instead. - \GlsXtrSetAltModifier now has a check to ensure '*' or '+' haven't been used as the alternative modifier. - corrected accessibility support for abbreviations - redefine \@gls at entry@field so that it uses \csuse instead of \csname (in the event commands like \glsentrytext are used in captions or section headings with bib2gls) Other changes: - added support for glossaries.sty 'disablemakegloss' option (introduced to glossaries.sty v4.45). - new package option 'prefix' automatically loads glossaries-prefix.sty - new abbreviation styles - new commands - additional checks and warnings See CHANGES file for complete list.
This package is located at http://mirror.ctan.org/macros/latex/contrib/glossaries-extra More information is at https://www.ctan.org/pkg/glossaries-extra
Thanks for the upload. For the CTAN Team Manfred Lotz CTAN is run entirely by volunteers and supported by TeX user groups. Please join a user group or donate to one, see https://ctan.org/lugs .

glossaries-extra – An extension to the glossaries package

This package provides improvements and extra features to the glossaries package. Some of the default glossaries.sty behaviour is changed by glossaries-extra.sty. See the user manual glossaries-extra-manual.pdf for further details.

glossaries-extra.sty requires the glossaries package and, naturally, all packages required by glossaries.sty.

Packageglossaries-extra
Version1.45 2020-04-01
Copyright2015–2020 Nicola Talbot
MaintainerNicola Talbot

Announcements

more

Guest Book Sitemap Contact Contact Author