CTAN Comprehensive TeX Archive Network

CTAN update: iftex

Date: March 7, 2020 9:33:26 PM CET
The LaTeX Team submitted an update to the iftex package. Version number: 1.0d License type: lppl1.3c Summary description: Am I running under pdfTeX, XeTeX or LuaTeX? Announcement text:
Update to iftex to remove a compatibility patch for scrbase that is not needed for current KOMA-Script releases, and could generate errors in some uses with existing \ifpdftex definitions, see https://github.com/latex3/iftex/issues/12
This package is located at http://mirror.ctan.org/macros/latex/contrib/iftex More information is at http://www.ctan.org/pkg/iftex CTAN is run entirely by volunteers and supported by TeX user groups Please join a user group or donate to one, see https://ctan.org/lugs
Thanks for the upload. For the CTAN Team Ina Dau --

iftex – Am I running under pdf, or Lua?

The package, which works both for Plain and for , defines the \ifPDF, \if, and \ifLua conditionals for testing which engine is being used for typesetting.

The package also provides the \RequirePDF, \Require, and \RequireLua commands which throw an error if pdf, or Lua (respectively) is not the engine in use.

Packageiftex
Version1.0d
MaintainerThe Team
Vafa Khalighi (inactive)

Announcements

more

Guest Book Sitemap Contact Contact Author