CTAN Comprehensive TeX Archive Network

CTAN update: glossaries-extra

Date: November 24, 2021 9:19:50 AM CET
Nicola Talbot submitted an update to the glossaries-extra package. Version number: 1.48 2021-11-22 License type: lppl1.3 Summary description: An extension to the glossaries package Announcement text:
* glossaries-extra.sty: - new command \glslinkwrcontent used to encapsulate link text and indexing within commands like \gls and \glslink. This adds grouping, which will hopefully fix issue #189 https://www.dickimaw-books.com/bugtracker.php?key=189 (spacing issues caused by whatsit) This is currently added as a trial. If no issues are reported it will be added to the base package as well. If the grouping causes a problem, redefine this command without it: \renewcommand*{\glslinkwrcontent}[1]{#1} - New multi (combined/compound) entry feature: \multiglossaryentry and associated commands See chapter "Multi (or Compound) Entries" for details. - New commands: \glssetcategoriesattribute \glssetcategoriesattributes - bug fix #190: hypergroup, \glsnavhyperlinkname and targetnameprefix don't work together https://www.dickimaw-books.com/bugtracker.php?key=190 - new abbreviation styles: long-only-short-sc-only long-only-short-sc-only-desc long-postshort-sc-user long-postshort-sc-user-desc - new debugging package option `showtargets` * glossaries-extra-bib2gls.sty: - added multi-entry commands for use with bib2gls.
This package is located at https://mirrors.ctan.org/macros/latex/contrib/glossaries-extra More information is at https://www.ctan.org/pkg/glossaries-extra
Thanks for the upload. For the CTAN Team Manfred Lotz CTAN is run entirely by volunteers and supported by TeX user groups. Please join a user group or donate to one, see https://ctan.org/lugs .

glossaries-extra – An extension to the glossaries package

This package provides improvements and extra features to the glossaries package. Some of the default glossaries.sty behaviour is changed by glossaries-extra.sty. See the user manual glossaries-extra-manual.pdf for further details.

glossaries-extra.sty requires the glossaries package and, naturally, all packages required by glossaries.sty.

Packageglossaries-extra
Version1.48 2021-11-22
Copyright2015–2021 Nicola Talbot
MaintainerNicola Talbot

Announcements

more

Guest Book Sitemap Contact Contact Author